KDE Asciiquarium
Screensavers
Score 70%
Description:

KDE Asciiquarium is a KDE screensaver based off of Kirk Baucom's FABULOUS asciiquarium program (http://www.robobunny.com/projects/asciiquarium/).

Or in other words, it's a simulation of an ocean scene, but using ASCII art instead.

NOTE This content is the KDE 3 version of the screensaver. I have not uploaded the KDE 4 port here because it is now included with KDE 4 in the kdeartwork module.

Note the screenshot preview will probably be a bit dark, view the full screenshot to see what it's more likely to look like.

To install:
Extract the tarball, and change to its directory (aasaver-0.3.2). In that directory, run the following:

./configure
make
make install (this may need run as root)

You will then be able to find Asciiquarium in the Miscellaneous category of the Screensaver Control Panel.

At this time the only option is the number of fish to have present.

Thanks to Maksim Orlovich for starting the project, and Kirk Baucom and Joan Stark for the asciiquarium program and ASCII Art.
Last changelog:

12 years ago

0.3.2 -- Initial public release.

Jedimaster

5 years ago

Quote:[root@Chiisai-Akuma aasaver-0.3.2]# ./configure
scons not installed, installing local copy.
scons: Reading SConscript files ...
File "/home/Jedimaster/Downloads/aasaver-0.3.2/scons-local-0.96.1/SCons/Tool/gas.py", line 1

import as

^

SyntaxError: invalid syntax

I cannot install this because of this error. I tried running ./scons by itself; however I recieved the same error.

Report

bittajam

7 years ago

It's my favorite except for the Matrix3D :)

Report

yurix

7 years ago

Beautiful!!! Thanks!!!

Report

kvoort

8 years ago

I have my aasciiquarium back!

To have it working under kde4, apply the supplied .diff patch to src/asciiquarium.desktop, which will modify it to meet kde4 standards, then configure, build, and install as usual.

After installing, the asciiquarium.desktop file needs to be moved from the old kde3 location to the new kde4 location. The configure scripts still rely on a tool (kde-config) which returns kde3 installation locations (usr/share/applnk), and I can't figure out how to fix this. The asciiquarium.desktop file needs to be moved to /usr/share/kde4/services/ScreenSavers/.

This should have it working under kde4.

---PATCH---


--- aasaver-0.3.2-old/src/asciiquarium.desktop 2005-09-16 22:01:41.000000000 -0400
+++ aasaver-0.3.2/src/asciiquarium.desktop 2008-11-05 11:22:06.000000000 -0500
@@ -2,10 +2,10 @@
Encoding=UTF-8
Exec=asciiquarium.kss
Icon=kscreensaver
-Type=Application
+Type=Service
+X-KDE-ServiceTypes=ScreenSaver
Actions=InWindow;Root;Setup
Name=Asciiquarium
-X-KDE-Category=Miscellaneous

[Desktop Action InWindow]
Exec=asciiquarium.kss -window-id %w

Report

jseabold

9 years ago

This looks great anybody have it working on KDE 4.*? Anyone know how to make it show up in the new System Settings?

Report

liegerm

9 years ago

If you get an error about uic, try installing the qt devel package. You also need the KDE headers which can be found in the kde devel package for your distro.

Works great! Thanks! I'm off to find an ASCII version of Quake 4...

Report

giofra

9 years ago

Hi!!!
After i wrote in the shell ./configure it's all ok...
but when i write make i receive this error message:
make: *** No targets specified and no makefile found. Stop.

after make install:
make: *** No rule to make target `install'. Stop.

Why???
Anyone??

Report

aztk

9 years ago

[root@1309-6 aasaver-0.3.2]# ./configure
scons not installed, installing local copy.
scons: Reading SConscript files ...
Checking for kde-config : kde-config was found
Checking for kde version : 3.5.7
Checking for the qt library : qt is in /usr/lib/qt3
Checking for uic : uic was not found - set QTDIR put it in your PATH ?
Unable to configure scons

then i try this
[root@1309-6 aasaver-0.3.2]# export QTDIR=/usr/lib/qt3
[root@1309-6 aasaver-0.3.2]# ./configure

but same error

what its wrong?
tnx

Report

lsolano

9 years ago

This screen saver installs without any problem on Mandriva 2008.

Thanks!

Report

carolinawren

9 years ago

I could not install in my Mandriva 2008 KDE.
Quote:[joonas@localhost aasaver-0.3.2]$ su
Password:
[root@localhost aasaver-0.3.2]# ./configure
scons not installed, installing local copy.
scons: Reading SConscript files ...
Checking for kde-config : kde-config was found
Checking for kde version : 3.5.7
Checking for the qt library : qt is in /usr/lib/qt3/
Checking for uic : uic was found as /usr/lib/qt3//bin/uic
Checking for moc : moc was found as /usr/lib/qt3//bin/moc
Checking for the qt includes : ok /usr/lib/qt3//include/
Checking for the kde includes : ok /usr/include/
scons: done reading SConscript files.
scons: Building targets ...
scons: Nothing to be done for `configure'.
scons: done building targets.
Generating ./Makefile
Generating ./src/Makefile

The Makefile(s) have been generated. Type:
`make' to build aa.kss, and
`make install' to install aa.kss.

[root@localhost aasaver-0.3.2]# make
processing AASaverConfig.kcfgc to get AASaverConfig.h and AASaverConfig.cpp
kconfig_compiler -dsrc src/asciiquarium.kcfg src/AASaverConfig.kcfgc
-I/usr/include/ -I/usr/lib/qt3//include/ -O2 -DNDEBUG -DNO_DEBUG -Wno-non-virtual-dtor -Wno-sign-compare -Wno-trigraphs -DQT_NO_TRANSLATION -I. -Isrc -Isrc -c -o src/AASaverConfig.o src/AASaverConfig.cpp
sh: -/: invalid option
Usage: sh [GNU long option] [option] ...
sh [GNU long option] [option] script-file ...
GNU long options:
--debug
--debugger
--dump-po-strings
--dump-strings
--help
--init-file
--login
--noediting
--noprofile
--norc
--posix
--protected
--rcfile
--restricted
--verbose
--version
--wordexp
Shell options:
-irsD or -c command or -O shopt_option (invocation only)
-abefhkmnptuvxBCHP or -o option
scons: *** [src/AASaverConfig.o] Error 2
make: *** [all] Error 2
[root@localhost aasaver-0.3.2]#
[joonas@localhost aasaver-0.3.2]$ su
Password:
[root@localhost aasaver-0.3.2]# ./configure
scons not installed, installing local copy.
scons: Reading SConscript files ...
Checking for kde-config : kde-config was found
Checking for kde version : 3.5.7
Checking for the qt library : qt is in /usr/lib/qt3/
Checking for uic : uic was found as /usr/lib/qt3//bin/uic
Checking for moc : moc was found as /usr/lib/qt3//bin/moc
Checking for the qt includes : ok /usr/lib/qt3//include/
Checking for the kde includes : ok /usr/include/
scons: done reading SConscript files.
scons: Building targets ...
scons: Nothing to be done for `configure'.
scons: done building targets.
Generating ./Makefile
Generating ./src/Makefile

The Makefile(s) have been generated. Type:
`make' to build aa.kss, and
`make install' to install aa.kss.

[root@localhost aasaver-0.3.2]# make
processing AASaverConfig.kcfgc to get AASaverConfig.h and AASaverConfig.cpp
kconfig_compiler -dsrc src/asciiquarium.kcfg src/AASaverConfig.kcfgc
-I/usr/include/ -I/usr/lib/qt3//include/ -O2 -DNDEBUG -DNO_DEBUG -Wno-non-virtual-dtor -Wno-sign-compare -Wno-trigraphs -DQT_NO_TRANSLATION -I. -Isrc -Isrc -c -o src/AASaverConfig.o src/AASaverConfig.cpp
sh: -/: invalid option
Usage: sh [GNU long option] [option] ...
sh [GNU long option] [option] script-file ...
GNU long options:
--debug
--debugger
--dump-po-strings
--dump-strings
--help
--init-file
--login
--noediting
--noprofile
--norc
--posix
--protected
--rcfile
--restricted
--verbose
--version
--wordexp
Shell options:
-irsD or -c command or -O shopt_option (invocation only)
-abefhkmnptuvxBCHP or -o option
scons: *** [src/AASaverConfig.o] Error 2
make: *** [all] Error 2
[root@localhost aasaver-0.3.2]#

Report

mscroggi

10 years ago

I love this screensaver.. I recently switched to an HP 8200 workstation. It is an x64 based machine (dual intel xeons).

When I attempt to compile the screensaver I get x86_64-suse-linux/bin/ld: cannot find -lqt-mt

Any ideas?

OS openSUSE 10.2 (X86-64)
Kernel 2.6.18.8-0.5-default x86_64
KDE 3.5.7
gcc 4.1.2

Any help would be greatly appreciated.

Monty

Report

Jebadius

11 years ago

Running on laptop, makes people at school look at me strange, I love it. Works well.

Report

Psypointer

11 years ago

hey, thats really nice! i´m using a notebook and the default aquarium screensavers are taking too much performance.. i like it! thank you!

Report

janet

11 years ago

I did the usual: ./configure, make, su, checkinstall. All fine until it comes to checkinstall (or likewise make install). I get the following error: "make: scons: command not found" and "make: *** [install] error 127".

Report

C

pynm0001

11 years ago

Odd. It went through make successfully and then didn't install?

Try doing (from the same directory)

"./scons install" to run the local scons manually, that would hopefully work.

Report

janet

11 years ago

Thanks, that works. But alas I cannot build a deb this way. I tried a checkinstall after installing it with ./scons install, but all I get is an empty deb. Never had those problems before - scons seems to make it a lot more complicated ... But the asciiquarium saver really is nice :)

Report

anz

11 years ago

thanks alot for that very nice screensaver!

Report

LinuxHungry

12 years ago

I'm anewbie to linux and I did have a few problems compileing under debian sarge....heres what I did to get it to work.

export QTDIR=/usr/share/qt3

apt-get install kde-devel
(not sure I spelled devel right)

then ./compile
make
make install

Report

czubin

12 years ago

That screensaver is so innovative O_o

Kind of freaks my buddies :)

Report

sessionID

12 years ago

Best thing to happen to a screen :)

Report

maarizwan

12 years ago

How about porting this QT-2.2 Aquarium to QT 3 (or QT 4) please visit: http://www.ratemyfishtank.com/aquarium_screensaver.php

Report

stomph

12 years ago

Really nice, thanks! :-)

Report

ch4n01r

12 years ago

Very cool :)

It would be even more cool if we could adjust the speed of the fishes :)

Report

sphere

12 years ago

I just wanted to say that I appreciate this screensaver for two reasons...

1. It's cool. How could ascii fish not be cool.
2. It was easy to build. Thanks for looking out for those of us that routinely botch compile-it-yourself installs.

P.S. I think that one of the messages may be incorrect during installation...

Type:
`make' to build aa.kss, and
`make install' to install aa.kss.

ought to read...
Type:
'make' to build asciiquarium.kss and
'makde install' to install asciiquarium.kss.

Thanks again.

Report

C

pynm0001

12 years ago

Good catch on the message. Too lazy to fix it though, sorry. :)

And yes, I always hated downloading packages that just wouldn't compile which is why I've tried to make it easy to build and install. It's a lot easier when you have SCons/bksys to help instead of the autotools though. ;)

Report

12 years ago

0.3.2 -- Initial public release.

product-maker 69 172

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.3.2
updated Sep 16 2005
added Sep 16 2005
downloads today
0
page views today 1