OpenOffice 1.1 pseudo-static themer

Various KDE 1.-4. Styles

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
Score 50.0%
Description:

Included:
----------

1. Static OOo crystal theme (light color and gray)

2. Script to change the background color of the static theme

3. Script for others to create new static (pseudo) openoffice toolbar/menubar icon themes which they can then post here or distribute

Install:
---------
See readme.first
Last changelog:

16 years ago

0.1 Initial release
0.12 Sync with the dynamic themer v. 0.5 (http://www.kde-look.org/content/show.php?content=7131)
Included an additional gray background
Improved docmentation

learninlinux

15 years ago

Geez... I cant even program but i figured this one out. ls is a linux command. use "dir". I had to execute some commands manually, but it worked for me as soon as I translated the script. play around with tclsh a bit. Notice that in paths, \ is ignored and / represents \ in the script. keep debugging and it works...

Report

cwchia

15 years ago

I get this error while running the gentheme script:

couldn't execute "ls":no such file or directory while executing

"exec ls -w 1 $ThemeDir > lst.txt"
(file "D:\OpenOffice.org\user\config\soffice.cfg\gentheme.tcl" line 276)

the bkColor.tcl script runs and leave a window with grey background opened.

What's wrong? please help. The theme looks great and I can actually 'entice' more win users to switch to opensource by getting their attention with this lovely theme.

Report

C

kol

15 years ago

To just use the static theme included, you should not need to run any scripts (see README).

Anyway, I was working on a small icon theme, but I am very busy till the end of this month, so I'll look into any issues after that.

Report

mgpeter

15 years ago

I am working on a gtk2 theme based on ximian's work, and have a few questions that have come up that maybe some of you can help me with.

1) Is there anyway to have 2 different sizes of icons, one for the interface and one for the menu icons ? Right now I am using 24x24 icons for both and the menus are Huge.

2) Is there any way to have the icons greyed out when the user cannot use the feature ? This is how the standard icons work.

3) Is there any way to just use the PNG images instead of the bitmaps, so we don't need to add a background color or supply multiple userimages for different background colors ?

4) Finally, where can I find the "slot list" for openoffice, the links i tried says the document has been moved.

Thanks, and you can view my work in process theme at "http://www.pcc-services.com/images/ootheme.png".

And I will make it available once I iron out a few items.

Report

C

kol

15 years ago

Hi,

Your work looks very nice. Here are the answers based on what I know (I could be wrong though).

1) Is there anyway to have 2 different sizes of icons, one for the interface and one for the menu icons ? Right now I am using 24x24 icons for both and the menus are Huge.
A: Once a slot number is associated with an icon, its size cannot be changed, irrespective of where you use it (menu or toolbar).

2) Is there any way to have the icons greyed out when the user cannot use the feature ? This is how the standard icons work.
A: Yes, it is possible. The config file from the link above also has an option for image-masking. However, for alpha-blended icons (like yours), image masking does not look nice (rather, looks quite ugly).

3) Is there any way to just use the PNG images instead of the bitmaps, so we don't need to add a background color or supply multiple userimages for different background colors ?
A: Nope.

4) Finally, where can I find the "slot list" for openoffice, the links i tried says the document has been moved.
A: http://oo-cs.sourceforge.net/tips/installmulti/816-7522.pdf

Report

mgpeter

15 years ago

I am finally done with a gtk2 theme featuring ximian icons. Thanks for all the help. This theme uses over 500 icons and replaces *Almost* all the default icons. Only the "new writer,etc icons" need replaced and one form icon which I couldn't find.

Anyway you can download the theme here
http://www.pcc-services.com/files/gtk2-ooo-theme_pre1-1.tar.gz

or if you just want the static them get it here
http://www.pcc-services.com/files/oootheme.zip

I cleaned the slotlist.csv file up and put it in somewhat of an organized list. If you just want the slotlist.csv file, grab it here
http://www.pcc-services.com/files/slotlist.csv

Thanks everyone for all the help and for creating these scripts.

Mike Petersen

Report

C

kol

15 years ago

Wow! excellent job :-)

Report

mgpeter

15 years ago

I am working on a gtk2 theme based on ximian's work, and have a few questions that have come up that maybe some of you can help me with.

1) Is there anyway to have 2 different sizes of icons, one for the interface and one for the menu icons ? Right now I am using 24x24 icons for both and the menus are Huge.

2) Is there any way to have the icons greyed out when the user cannot use the feature ? This is how the standard icons work.

3) Is there any way to just use the PNG images instead of the bitmaps, so we don't need to add a background color or supply multiple userimages for different background colors ?

4) Finally, where can I find the "slot list" for openoffice, the links i tried says the document has been moved.

Thanks, and you can view my work in process theme at "http://www.pcc-services.com/images/ootheme.png".

And I will make it available once I iron out a few items.

Report

TheK

15 years ago

I just get a crash here if OOo tries to load any image.
debian sid, OpenOffice 1.1.0-3.

I needed to create soffice.cfg (if that helps).

Report

C

kol

15 years ago

It is a known issue and is listed in the dynamic theming script:
http://www.kde-look.org/content/show.php?content=7131

From what other Debian users have discussed with me, it may be due to a Ximian patch that debian applied to standard OOo.

Report

d1g174l

15 years ago

Great Work!

In the screenshot I see that you got an OSX type stipple effect to carry through Mozilla and Evolution...how did you do this? I keep getting an old looking grey in evolution.

Report

C

kol

15 years ago

:) That was a gnome theme I found on art.gnome.org:
http://art.gnome.org/themes/gtk2/432.php

Report

spiritraveller

15 years ago

To get the script to execute in windows, do the following...

1) Install ImageMagick from here http://www.imagemagick.org/

2) Install ActiveTcl from here
http://www.activestate.com/Products/Download/Download.plex?id=ActiveTcl

3) Edit the file bkColor.tcl and change "exec convert" to the following
exec "c:/Program Files/ImageMagick-5.5.7-Q8/convert"

Windows has a file in c:\windows\system32\convert.exe which ActiveTcl wants to run instead of the ImageMagick program. So you just need to point it to the right file.

Report

WINDOOF

16 years ago

Great work! Looks fine! But it would be great to have a possibility to download a zip-file as well! Thanks in advance.

Report

mcanedo

16 years ago

It looks great, but there are some icons like, paragraph alignmet (left, center, etc) that are applied only to Write and not to Calc.
Is that normal?
Is there a way to correct it?
Thanks,
Miguel

Report

C

kol

15 years ago

Need to set icons for that. Will do that in the next release (which might get delayed though)

Report

maximusotter

16 years ago

Scrumptious! I run a funky color in KDE and all of OOo except the buttons comply with this. Problem solved, brilliant! Thanks!

Report

deech

16 years ago

hi,

very nice...escpeccially evolution in your screenshot.....could you please share those icons with us to?

deech

Report

C

kol

16 years ago

Finally posted it :)
http://www.kde-look.org/content/show.php?content=8950

Report

C

kol

16 years ago

sure!

Report

nom

16 years ago

Yes this theme works under windows too!!

Great work!

For windows you will have to extract ALL the files to the ~/soffice.cfg folder.

Thanks,

Nom

Report

jonest1

16 years ago

I copied the genBitmaps directory to ~/OpenOffice.org1.1.0/user/config as well as imagelist.xml. However, I do not see the new icons. Please assist as I've been looking for something like this. The screenshot looks great.

Report

C

kol

16 years ago

you need to copy them to:
OpenOffice.org1.1.0/user/config/soffice.cfg

If soffice.cfg directory does not exist, you'll have to create it first.

See if it works then :-)

Report

jonest1

16 years ago

Thanks a lot for the help. It looks great and I cannot wait for future versions. Your hard work is appreciated.

Report

16 years ago

0.1 Initial release
0.12 Sync with the dynamic themer v. 0.5 (http://www.kde-look.org/content/show.php?content=7131)
Included an additional gray background
Improved docmentation

12345678910
product-maker Base: 4 x 5.0 Ratings
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
updated Oct 25 2003
added Oct 22 2003
downloads 24h
0
pageviews 24h 1