profile-image

yield65

Yield Cito Mexico, Mexico
Now Dock Plasmoid 0.4.0 Various Plasma 5 Stuff
51 comments
Score 83%
83 Likes
17 Dislikes
Mar 26 2017
My error:
Error loading QML file: file:///home/myuser/.local/share/plasma/plasmoids/org.kdelook.nowdock/contents/ui/main.qml:9:1: module "org.kde.taskmanager" is not installed
Sep 17 2016
Yasp-Scripted (Systemmonitor) v1.0.8a 1.0.8a Plasma 4 Widgets
301 comments
Score 83%
83 Likes
17 Dislikes
Feb 25 2011
Thank you for your reply, I ended with something like this:
sensor name="WLan1Ip" type="program" cmd=%/sbin/ifconfig wlan1 2>/dev/null | grep 'inet addr' | cut -d':' -f 2 | cut -d' ' -f1%
sensor name="Wlan1BitRate" type="program" cmd=%/usr/sbin/iwconfig wlan1 2>/dev/null | grep 'Bit' | cut -d'=' -f2 | cut -d' ' -f1-2%
sensor name="Wlan1Quality" type="program" cmd=%/usr/sbin/iwconfig wlan1 2>/dev/null | grep 'Link' | cut -d = -f2 | cut -d ' ' -f1%
sensor name="Wlan1Essid" type="program" cmd=%/usr/sbin/iwgetid wlan1 |awk -F ":" '{print $2}'%

And an interval of "3000". For the speed meter I finally used mrtg as daemon. Jul 12 2011
I was modifying the script so that is show another wlan device, I'm on a laptop with an internal wireless as wlan0 but I use 2 other devices, wlan1 is USB the other ath0 is pcmcia.
My problem is with the system monitor sensors for download/upload speed. If I turn on the laptop with 1 or 2 of those cards disconnected then I just see a message that says it's waiting for one of those sensors and nothing else shows up.
Is there a way to bypass this so If YASP doesn't find the sensor it can keep working with a null or 0 value?

The other thing is that I changed the use of iwconfig to this:
cmd=%/usr/sbin/iwgetid wlan0 |awk -F ":" '{print $2}'%
So that it shows the ESSID of the currently connected network on opensuse (11.4) because it wasn't working with iwconfig and you can use it easier if you have more than one wireless interface.

Thnx and best regards. May 31 2011