profile-image

skulptor

Christoph Feck , Germany

Skulpture

Other Plasma Styles Jul 31 2017
Score 74%
74 Likes
26 Dislikes

Domino

Other Plasma Styles Jul 31 2017
Score 67%
67 Likes
33 Dislikes
Smaragd (Emerald for KDE)

Other Plasma Styles 120 comments

Score 86%
86 Likes
14 Dislikes
Jul 31 2017
I didn't request inclusion into Plasma releases, because it contains unmaintained code written by the original Emerald team, and because it depends on obsolete glib2 library. - 2 days ago
I am still on KDE4, and not sure when I will switch. Right now, there are too many bugs, especially with decoration settings. - Apr 29 2015
If you compile from source, you also need the required -dev packages. Just follow the error messages. - Apr 21 2014
They are working good unless you use the Offset values to shift the shadows. I usually like them larger at the bottom, but shifting them down results in rendering errors.

The git master of the Skulpture repository has hardcoded shadows that are shifted, but it is easier here, because the Skulpture window decoration is not transparent. - Dec 15 2011
You need to compile Smaragd from git master to get the Blur effect working. - Dec 13 2011
Fixed, was missing "&include_home=true". Thanks! - Jun 15 2011
"cairo.pc" is the pkgconfig file that should be installed together with cairo-dev package. Without that file, Smaragd cannot find Cairo. Maybe your distribution just forgot to ship it.

It is possible that "FindCairo.cmake" is intended to work without the .pc file, but neither did I write it, nor is my cmake voodoo good enough to fix it. You might ask someone who knows cmake better. Sorry.

If you have a patch for "FindCairo.cmake", please add it or send it to its author. - May 07 2011
Could you check if deleting CMakeCache.txt helps? It looks like you previously tried cmake configure without cairo-dev installed.

If this does not help, please pastebin the cairo.pc file. - May 07 2011
Could you pastebin the contents of "CMakeCache.txt" and the location of the "cairo.h" include file? - May 07 2011
Yep, I already added it to Smaragd in git repository. - Apr 30 2011
Bug reported. When it is fixed, I will add the blur property to Smaragd to make it work.

https://bugs.kde.org/show_bug.cgi?id=271191 - Apr 18 2011
If Smaragd does not appear in the System Settings window decoration list, then you have not installed Smaragd.

Even with no themes installed, Smaragd is listed there using a simple fallback theme. - Feb 27 2011
Check if you have kdebase-workspace headers and libraries installed.

If you are using Gentoo, please report the bug to Gentoo developers. This bug (linker error when using KDE4Workspace) is at least two years old, and I wonder why they did not fix it yet. - Jan 31 2011
No chance. Smaragd contains the Emerald engines, and Emerald is not maintained anymore. I don't feel like adding 5000+ lines of unmaintained code to KDE.

If someone reports a bug for the engines, there is no one who could fix it (award will go to the first who fixes the rendering glitches visible with Cairo 1.10...)

Which leads us to the second problem: KDE does not need a Cairo dependency when it has Arthur (Qt's rasterization framework).

But what I hope for is to make KWin ready for multiple themeable decoration engines, so that you can plug-in Smaragd or deKorator and have their themes appear in the decoration list and "Get New Themes..." dialog.

There are some technical difficulties in KWin and KNewStuff which make that impossible right now, so 4.7 earliest. - Nov 17 2010
It is the inactive text halo that is too bright, so change that to inactive_text_halo=#rrggbb but also play with the alpha values. - Oct 04 2010
Skulpture

Other Plasma Styles 367 comments

Score 74%
74 Likes
26 Dislikes
Jul 31 2017
Use branch 'five' of https://github.com/cfeck/skulpture

To build, cd into src, run qmake-qt5, make, then copy the libskulpture.so into QT5_DIR/plugins/styles - Feb 15 2017
I have just moved it to github, link on website fixed. - Dec 20 2016
Someone who ported the kde-look.org site to store.kde.org incorrectly moved this to QtCurve category, but Skulpture is not a QtCurve setting. - Sep 04 2016
Do you have a backtrace? I tried compiling it, and only got a dialog asking for a MPD server setup, which I do not have. - Oct 19 2015
If there are issues, I can try fixing them. - Oct 12 2015
Thanks for your comment! In addition to supporting recent KDE 4 versions, a port to Qt5 is available in the "five" branch at http://quickgit.kde.org/?p=scratch%2Fcfeck%2Fskulpture.git

To build, cd into src, run qmake-qt5, make, then copy the libskulpture.so into QT5_DIR/plugins/styles.

(and sorry for the late reply) - Sep 07 2014
Well, Debian packages are still at 0.2.0, but Skulpture had a 0.2.4 release a few years ago already (and it still builds with today's KDE).

If you cannot find someone willing to maintain the Debian package, why not start looking how you could do it? You are born to learn. - Sep 23 2013
http://quickgit.kde.org/?p=scratch%2Fcfeck%2Fskulpture.git&a=shortlog&h=071966772de4c0198ff88fdc6de6fecf841499cd - Aug 27 2013
Report the bug to the author of the GTK engine that you use. - Jul 31 2013
If you do not want to compile it yourself on your system, you have to wait until someone provides updated Kubuntu packages. - Jul 01 2013
My opinion is that a day has too few hours, that's why I never found the time to work on Skulpture again. Patches that add the new KDE features (shadows, dragging, tabbing, menu button) are welcome. - Mar 05 2013
Thanks, I removed the unmaintained links. - Jan 05 2013
Sorry, what preview theme? - Jul 14 2011
Patches welcome, or just commit to git master. - Jul 12 2011
Thanks :) - Jun 16 2011
deKorator

Various KDE 1.-4. Styles 133 comments

Score 85%
85 Likes
15 Dislikes
Aug 04 2017
DeKorator has not been ported to Plasma 5, it only works with KDE 4. - Jan 08 2016
Do NOT uninstall kwin, you might be left with an unusable system.

deKorator requires a working kwin. The reason for your error message is that you are using an old package. Use a package of deKorator that is explicitely compiled for your distribution version, or compile it yourself. - Sep 10 2014
Try enabling KWin compositing. - Feb 18 2014
Try enabling KWin compositing. - Jun 23 2013
The git repository works fine, just tried a clean checkout. It also still builds, with today's KDE master (4.10) and newest gcc (4.7.2). Please pastebin error messages. - Sep 26 2012
... it's more complicated, see my followup comment in the review requested linked from the KDE bug 293718. - Mar 24 2012
Thanks :) There is one problem with the patch: The background is not simply "midTitle", but could also be "leftButtons" or "rightButtons", depending on which side the button is at. - Mar 24 2012
You can use XRender compositing for old hardware, I am currently also using it on my rusty i945 chip.

As for updates in deKorator and Smaragd, I am waiting until the API changes coming for future KDE versions have settled, so that I can implement shadows etc. correctly.

It was also hinted that deKorator is going to be rewritten in QML by the KWin team, so that any efforts on the C++ code would be wasted.

(And yeah, I know that instead of waiting, I should actually help contributing those changes, but my priorities are elsewhere, sorry.) - Mar 01 2012
Keep compositing enabled, and only disable all effects that you do not want. - Feb 21 2012
To get blur working, you also need to return true for "AbilityUsesAlphaChannel". - Apr 29 2011
Bug reported. When it is fixed, I will add the blur property to deKorator to make it work.

https://bugs.kde.org/show_bug.cgi?id=271191 - Apr 18 2011
Just curious, which theme did you use? I don't know any deKorator themes with transparency, so you might talking about a completely different issue. - Dec 22 2010
deKorator supports blur with KDE 4.5.

Starting with KDE 4.6 there is new API, and decorations have to explicitly enable blur. I will update deKorator to support the new API in the future.

If you can compile from source, simply include AbilityUsesBlurBehind in the DeKoratorFactory::supports() function. - Dec 21 2010
Favorites Launcher

KDE 1.-4. Improvements 22 comments

Score 68%
68 Likes
32 Dislikes
Jul 13 2017
Forgot "cd build" after "mkdir build". - Aug 31 2015
It looks like you did not use the correct back-ticks to put the kde4-config command into the cmake invocation.

Try this:

git clone git://anongit.kde.org/scratch/cfeck/containmentaction-favorites.git
cd containmentaction-favorites
mkdir build
cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..
make
sudo make install/fast

Then restart session. - Aug 31 2015
http://quickgit.kde.org/?p=scratch/cfeck/containmentaction-favorites.git

v0.1 tag - Jul 31 2013
Unless you tell cmake where to install, it will always default to /usr/local

Use cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` - Feb 28 2013
Are you sure you are using version 0.2? It works fine here, even when configured to use the RMB. - Feb 15 2012
Copy full path

System Software 13 comments

Score 52%
52 Likes
48 Dislikes
Aug 24 2013
How do you do it, if you need the URL of the current visible directory? - Aug 25 2013
krep

System Software 11 comments

Score 61%
61 Likes
39 Dislikes
Sep 08 2011
Qt uses value types for many data types, so you always get a copy of those returned from many functions. Because of reference counting, those copies are fast, though.

To change the cursor position, use QTextEdit::setTextCursor(). You can pass your own cursor positions, or the position returned from textCursor(). - Sep 10 2011
Atelier

Plasma Themes

Score 78%
78 Likes
22 Dislikes
Feb 19 2009