kffmpegthumbnailer

Video Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

5
5.7
Available as/for: -
Description:

kffmpegthumbnailer is a video thumbnailer for kde based on ffmpegthumbnailer. The thumbnailer uses ffmpeg to decode frames from the video files, so supported videoformats depend on the configuration flags of ffmpeg.

This thumbnailer was designed to be as fast and lightweight as possible.
Last changelog:

11 years ago

version 1.1.0 (January 6, 2010)
- Updated to ffmpegthumbnailer 2.0.0 interface

version 1.0.1 (December 28, 2009)
- Fixed thumbnails not being generated for filenames containing non-ascii characters (Thanks to fedux.c)

Version 1.0.0 (December 24, 2009)
- Initial release

C

DirkVdb

11 years ago

For some reason -lffmpegthumbnailer is not in your ldflags.

what does "pkg-config --libs libffmpegthumbnailer" output on your system?

Report

Quintasan1

11 years ago

Uhm, sorry for the spam. That's the output, I figured that I was missing libavformat-dev and libswscale-dev but I still get this error :(

Report

Jakarta

11 years ago

it is really fast and light. Would be great if it would replace the mplayer plugin.

Report

tsujan

11 years ago

This thumbnailer is far better than MPlayerThumbs. Contrary to MPlayerThumbs, which eats up CPU, kffmpegthumbnailer is light and fast. Thanks for this nice application!

Report

yoann21

11 years ago

There are other debian packages here :
https://launchpad.net/~samrog131/+archive/ppa

Report

C

DirkVdb

11 years ago

As long as ubuntu doesn't upgrade ffmpegthumbnailer, use version 1.0.1 of kffmpegthumbnailer. There is no difference between 1.0.1 and 1.1.0 only compatibility with ffmpegthumbnailer.

Report

fabrizio2210

11 years ago

I've error when I type make:

/home/fabrizio/Downloads/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:36: error: ‘ffmpegthumbnailer’ has not been declared
/home/fabrizio/Downloads/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:36: error: ISO C++ forbids declaration of ‘VideoThumbnailer’ with no type
/home/fabrizio/Downloads/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:36: error: expected ‘;’ before ‘m_Thumbnailer’
/home/fabrizio/Downloads/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:37: error: ‘ffmpegthumbnailer’ has not been declared
/home/fabrizio/Downloads/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:37: error: ISO C++ forbids declaration of ‘FilmStripFilter’ with no type
/home/fabrizio/Downloads/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:37: error: expected ‘;’ before ‘m_FilmStrip’

I've installed libffmpegthubnailer and libffmpegthubnailer-dev.
This is cmake output:
-- checking for module 'libavutil'
-- found libavutil, version 49.15.0
-- checking for module 'libavformat'
-- found libavformat, version 52.31.0
-- checking for module 'libavcodec'
-- found libavcodec, version 52.20.0
-- checking for module 'libswscale'
-- found libswscale, version 0.7.1
-- checking for module 'libffmpegthumbnailer'
-- found libffmpegthumbnailer, version 1.0.0
-- Configuring done
-- Generating done

Report

fabrizio2210

11 years ago

Sorry, I tried to compile with old version of libffmpegthumbnailer.

Report

gobonja

11 years ago

I tried installing kffmpegthumbnailer as explained in INSTALL file. I am using Kubuntu 9.10, KDE 4.4.
I get this error message:

-- The CXX compiler identification is unknown
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:84 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/marko/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:3 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

Report

C

DirkVdb

11 years ago

Do you have g++ installed?

run:
sudo apt-get install build-essential

Report

gobonja

11 years ago

Doesn't work. But error message is now different:

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:84 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/marko/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:3 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

Report

fabrizio2210

11 years ago

You have to install kdelibs5-dev.
sudo apt-get install kdelibs5-dev

Report

fabrizio2210

11 years ago

yes

Report

gobonja

11 years ago

How do I install ffmpegthumbnailer-2.0.0? I downloaded tar.gz from http://code.google.com/p/ffmpegthumbnailer/downloads/detail?name=ffmpegthumbnailer-2.0.0.tar.gz

Report

gobonja

11 years ago

Command line cmake . -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` works now. Command make has these error:

[ 50%] Built target kffmpegthumbnailer_automoc
[ 50%] Building CXX object CMakeFiles/kffmpegthumbnailer.dir/kffmpegthumbnailer_automoc.o
In file included from /home/marko/Desktop/kffmpegthumbnailer-1.1.0/moc_kffmpegthumbnailer.cpp:10,
from /home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer_automoc.cpp:4:
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:23:51: error: libffmpegthumbnailer/videothumbnailer.h: No such file or directory
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:24:50: error: libffmpegthumbnailer/filmstripfilter.h: No such file or directory
In file included from /home/marko/Desktop/kffmpegthumbnailer-1.1.0/moc_kffmpegthumbnailer.cpp:10,
from /home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer_automoc.cpp:4:
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:36: error: ‘ffmpegthumbnailer’ has not been declared
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:36: error: ISO C++ forbids declaration of ‘VideoThumbnailer’ with no type
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:36: error: expected ‘;’ before ‘m_Thumbnailer’
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:37: error: ‘ffmpegthumbnailer’ has not been declared
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:37: error: ISO C++ forbids declaration of ‘FilmStripFilter’ with no type
/home/marko/Desktop/kffmpegthumbnailer-1.1.0/kffmpegthumbnailer.h:37: error: expected ‘;’ before ‘m_FilmStrip’
make[2]: *** [CMakeFiles/kffmpegthumbnailer.dir/kffmpegthumbnailer_automoc.o] Error 1
make[1]: *** [CMakeFiles/kffmpegthumbnailer.dir/all] Error 2
make: *** [all] Error 2

Report

fabrizio2210

11 years ago

What is the version of libffmpegthumbnailer?
The 1.1.0 version of kffmpegth.. is made for libffmpeg.. 2.0.
If you want kffmpegth.. for karmic: https://launchpad.net/%7Esamrog131/+archive/ppa/+files/kffmpegthumbnailer_1.0.1%7Ekarmic%7Eppa1_i386.deb

Report

gobonja

11 years ago

It works now. Is this older version of kffmpegthumbnailer?

Report

Kwellmeister

11 years ago

There's no official debian package for ffmpegthumbnailer 2.0.0 right now, so I made one. Please pick it up here:

http://harrys-home.gmxhome.de/ffmpegthumbnailer_2.0.0-1_i386.deb

After installing that the new version of kffmpegthumbnailer works well.

Thanks for your great work !

Regards

Harry

Report

Apopatos

11 years ago

This one should become the default thumbnailer for KDE 4.4.

Report

Apopatos

11 years ago

Ok I installed the newer version, disabled Mplayer Thumbs, enabled kffmpegthumbnailer and WOW! It's fast :)
Maybe the problem with the previous version (no previews at all) was because my folders had greek names?

Report

C

DirkVdb

11 years ago

Glad it works, it was indeed the greek names that were causing troubles.

Report

KFreakz

11 years ago

A big thanks for this great plugin. I always hated using thumbnailers before, because they all were so ugly slow. This thumbnailer is really fast. It´s just fun to use it.

Thank U very much! :-)

Report

Apopatos

11 years ago

I had ffmpegthumbnailer installed in my Gentoo and I had video preview. Now I installed kffmpegthumbnailer How I choose this one instead of the previous one?

thank you

Report

ssuominen

11 years ago

1. Start Dolphin
2. Go to "Settings"
3. Go to "Configure Dolphin"
4. Go to "General"
5. Go to "Previews"
6. Select "kffmpegthumbnailer" to show "Video Files" instead of "MPlayerThumbs"

At least that's what I did...

Report

Apopatos

11 years ago

Thanks, but it doesn't work though. I get not preview when disabling ffmpegthumnailer and enabling kffmpegthumnailer.

Report

11 years ago

version 1.1.0 (January 6, 2010)
- Updated to ffmpegthumbnailer 2.0.0 interface

version 1.0.1 (December 28, 2009)
- Fixed thumbnails not being generated for filenames containing non-ascii characters (Thanks to fedux.c)

Version 1.0.0 (December 24, 2009)
- Initial release

12345678910
1
product-maker TheTrueNightwalker Mar 27 2012 9 excellent
Be the first to comment
Kwellmeister
Jan 07 2010
devport
Jan 04 2010
yoann21
Dec 28 2009
Apopatos
Dec 28 2009
KFreakz
Dec 27 2009
File (click to download) Version Description PackagetypeArchitectureRelease ChannelDevices Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
1.1.0
updated Jan 07 2010
added Dec 24 2009
downloads 24h
0
mediaviews 24h 0
pageviews 24h 4
System Tags app software