Subtitle Composer

Video Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

16
7 .9
Description:

A text-based subtitles editor.

Translators wanted:
If you want to help, translate the program into your language and send me the results.

Note for translators:
Please, before starting a translation make sure there isn't one for your language already (or if there is an unmaintained one).
Currently maintained translations include Brazilian Portuguese, Bulgarian, Czech, French, German, Italian, Russian, Serbian (Cyrillic and Latin), Spanish, Polish and Ukrainian. Greek and Hungarian translations are currently unmaintained.
Last changelog:

11 years ago

Version 0.5.3:
- added Czech, Brazilian Portuguese, Bulgarian, French and German translations contributed by Petr Gadula, Marcio P. Moraes, Petar Toushkov, Thomas Gastine and Panagiotis Papadopoulos respectively
and updated Spanish translation
- added Kross powered scripting interface with some basic examples in Ruby, Python and JavaScript
- added action to translate subtitles using Google translation services
- fixed many bugs including some that would crash the application
* selecting a file from the recently opened list could crash the application when using Qt 4.5
* video playback was completely broken with Qt 4.5
* bugs related to searching text and errors
* bugs related to undo/redo that could result in a crash
- other minor fixes, user interface changes and improvements

C

attendant

12 years ago

kross scripting support is planned after the (already in progress) port to KDE4.

Report

BorgQueen

12 years ago

Hi just build 0.3, but it doesn't play AVIs. Just says it can't play the file. The older version doesn't have a problem.

If others are having this problem too. I would be more than happy to help figure it out.

I invite you to join us some time on freenode,
#arklinux

Thank again for the app...

Report

C

attendant

12 years ago

i can't reproduce this problem with either mplayer or gstreamer.
what video backend are you using?

Report

BorgQueen

12 years ago

mplayer

Report

jayenell

12 years ago

Same here. Kubuntu 7.10 with mplayer 1.0~rc2

Report

BorgQueen

12 years ago

Its playing now. I don't know why but it is. Must have been a glitch in my system. I would check to make sure you have the latest stable release of mplayer. Try purging and reinstalling mplayer as well. Clear any related caches.

Report

BorgQueen

12 years ago

Oh and BTW, great app. I love it. Very useful.

Report

BorgQueen

12 years ago

Hi,

Hi I'm one of Ark Linux's devel, just to let you know...

You may confuse people with Ark when you really mean Arch.

Thanks..

Report

C

attendant

12 years ago

you're right of course... sorry.

Report

BorgQueen

12 years ago

No Sorrys here. Save them for when you sit on the cat!

Report

ALIUM

12 years ago

PKGBUILD is in AUR.
- with gstreamer backend:
http://aur.archlinux.org/packages.php?do_Details=1&ID=14301&O=0&L=0&C=0&K=subtitlecomposer&SB=n&SO=a&PP=25&do_MyPackages=0&do_Orphans=0&SeB=nd

- with mplayer backend:
http://aur.archlinux.org/packages.php?do_Details=1&ID=14306&O=0&L=0&C=0&K=subtitlecomposer&SB=n&SO=a&PP=25&do_MyPackages=0&do_Orphans=0&SeB=nd

Report

vip

12 years ago

Very nice app. What "Polska" format looks like? Haven't seen/heard about that one.

Report

vip

12 years ago

Some feature requests:
- would be great having "from selected line" in "Apply action to" in "Shif lines" option too
- if there's selection, the "Selected lines" should be checked by default.

Report

amigib

12 years ago

Sorry for that mess, its my fault.

The format is TMPlayer and really big thanks to author for making it work :)

Report

anubisg1

12 years ago

opensuse rpm upgrades to version 0.3 (avaible in the same link) (packman repo

Report

lele85

12 years ago

First of all thank you for this good piece of software.

I've made a DEB for kubuntu gutsty 7.10!
You can find in my blog at this page:

[url]http://italyanker.wordpress.com/2008/01/08/deb-subtitle-composer-03-per-kubuntu-gutsy/[url]

Report

gemidjy

12 years ago

every single file that I tried to add in this application was reported as unknown type:

Subtitle Composer doesn't know of xvid
Subtitle Composer doesn't know of avi
Subtitle Composer doesn't know of mpeg2
Subtitle Composer doesn't know of everything

hope I am mistaken somehow

Report

C

attendant

12 years ago

yes, you're mistaken. it seems you're using the "open subtitle" option to load a video file (you should use that to select the subtitle file and the "open video" option to select the video).

Report

spg76

12 years ago

First of all, great app.
Secondly, I have a feature request.
I think that a dialog with information about the "errors" in the subtitle would be very useful. You know, like the one on "Subtitle Workshop" that tells you which line is too long, which line has a short duration, etc. based on the parameters that were set by the user.
Thanks.

Report

C

attendant

12 years ago

this and support for translating subtitles is planned for next version.
a non definitive plan of next versions features can be found on the TODO file.

Report

spg76

12 years ago

Great, I'm looking forward to it.
Thank you for the reply.

Report

BorgQueen

12 years ago

I finally got around to building your app. Its wonderful. I love the on the fly editing. I'm going to recommend it to our devel leaders for inclusion in our distros Ark Linux and Yoper.
Well done and thanks!

Report

jirityr

12 years ago

Hello,

I have made an ebuild for Gentoo users. If you want, you can add the link:
http://bugs.gentoo.org/show_bug.cgi?id=202503

Cheers,
Jiri

Report

prizident

12 years ago

mplayer doesn't show ssa files produced by the program and in ass files styles are messed up

Report

C

attendant

12 years ago

i'll take a look at it.

Report

11 years ago

Version 0.5.3:
- added Czech, Brazilian Portuguese, Bulgarian, French and German translations contributed by Petr Gadula, Marcio P. Moraes, Petar Toushkov, Thomas Gastine and Panagiotis Papadopoulos respectively
and updated Spanish translation
- added Kross powered scripting interface with some basic examples in Ruby, Python and JavaScript
- added action to translate subtitles using Google translation services
- fixed many bugs including some that would crash the application
* selecting a file from the recently opened list could crash the application when using Qt 4.5
* video playback was completely broken with Qt 4.5
* bugs related to searching text and errors
* bugs related to undo/redo that could result in a crash
- other minor fixes, user interface changes and improvements

12345678910
10
product-maker jolugaju Jul 30 2018 9 excellent
Everything okay but one simple thing: I can't hide the Video Player or the Waveform.
product-maker alex-l Oct 17 2016 9 excellent
product-maker dubious Oct 27 2015 9 excellent
product-maker purplehuman Oct 17 2015 9 excellent
product-maker ArneBab May 27 2015 9 excellent
product-maker Etemenanki Mar 04 2012 9 excellent
product-maker fsmonteiro Apr 11 2011 9 excellent
product-maker LazyKent Feb 08 2011 9 excellent
product-maker Kosava Jan 16 2011 9 excellent
product-maker Vytax Oct 13 2010 9 excellent
Be the first to comment
bialyikar
Jan 27 2015
maxrd2
Nov 24 2013
AlmaTlust
May 15 2012
Etemenanki
Mar 04 2012
hteles
Dec 30 2010
rvernucio
Aug 31 2010
squall38
Aug 05 2010
AndreAPL
May 09 2010
AlexDusty
Feb 22 2010
giricz81
Dec 10 2009
KopiasCsaba
Jun 17 2009
brdn25
May 30 2009
YAFU
May 25 2009
mononoke
Mar 10 2009
adundovi
Mar 01 2009
pvt14
Jan 02 2009
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.5.3
updated May 25 2009
added Nov 15 2007
downloads 24h
0
mediaviews 24h 0
pageviews 24h 6
System Tags app software