Gmail Feed
Plasma 5 Widgets
Score 69%
Description:

Gmail Feed is a plasmoid for Plasma 5. It provides a list of your unread emails from your Gmail inbox. You also get notified when you receive new messages.

paulikos

5 months ago

Hi! I try install it, but i receive the next error message:

CMake Error at CMakeLists.txt:8 (find_package):
Could not find a package configuration file provided by "ECM" (requested
version 0.0.11) with any of the following names:
ECMConfig.cmake
ecm-config.cmake
Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
to a directory containing one of the above files. If "ECM" provides a
separate development package or SDK, be sure it has been installed.
-- Configuring incomplete, errors occurred!
See also "/home/paulik-maui/Letöltések/gmailfeed-1.1/build/CMakeFiles/CMakeOutput.log".

Any help?

Report

anthon38

5 months ago

As the error says, you need to install the Extra Cmake Modules. The name of the package depends on your distribution.

Report

paulikos

5 months ago

Thanks! I use Maui 17.03 (with plasma 5.9). I installed the ECM, but i recieved an other error message:

CMake Deprecation Warning at /usr/share/ECM/kde-modules/KDEInstallDirs.cmake:324 (message):
LIB_INSTALL_DIR is deprecated, use KDE_INSTALL_LIBDIR instead.
Call Stack (most recent call first):
/usr/share/ECM/kde-modules/KDEInstallDirs.cmake:418 (_define_relative)
CMakeLists.txt:11 (include)
-- Looking for __GLIBC__
-- Looking for __GLIBC__ - found
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:26 (find_package):
Could not find a package configuration file provided by "Qt5Quick" with any
of the following names:
Qt5QuickConfig.cmake
qt5quick-config.cmake
Add the installation prefix of "Qt5Quick" to CMAKE_PREFIX_PATH or set
"Qt5Quick_DIR" to a directory containing one of the above files. If
"Qt5Quick" provides a separate development package or SDK, be sure it has
been installed.
Call Stack (most recent call first):
CMakeLists.txt:15 (find_package)
-- Configuring incomplete, errors occurred!
See also "/home/paulik-maui/Letöltések/gmailfeed-1.1/build/CMakeFiles/CMakeOutput.log".

Sorry, my english is very poorly, and i can't all understand !

Report

anthon38

5 months ago

You need to install qtdeclarative5-dev.
When you encounter an error like this, just google the name of the missing file (in this case Qt5QuickConfig.cmake) + ubuntu, usually the result from packages.ubuntu.com tells you the name of the package you need

Report

paulikos

5 months ago

I am very grateful. Thanks for your help! I made it after any step with the missing files to the make install phase and now a fatal error message:

.....Building CXX object plugin/CMakeFiles/gmailfeedplugin.dir/notification.cpp.o
/home/paulik-maui/Letöltések/gmailfeed-1.1/plugin/notification.cpp:22:25: fatal error: KNotification: No such file or directory
compilation terminated.
plugin/CMakeFiles/gmailfeedplugin.dir/build.make:110: recipe for target 'plugin/CMakeFiles/gmailfeedplugin.dir/notification.cpp.o' failed
make[2]: *** [plugin/CMakeFiles/gmailfeedplugin.dir/notification.cpp.o] Error 1
CMakeFiles/Makefile2:155: recipe for target 'plugin/CMakeFiles/gmailfeedplugin.dir/all' failed
make[1]: *** [plugin/CMakeFiles/gmailfeedplugin.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2

Report

anthon38

5 months ago

Try to clean the build directory and then rerun cmake and make again. If it doesn't work I suggest you ask on the forum of your distribution.

Report

paulikos

5 months ago

Thanks for your help and patient!

Report

paulikos

5 months ago

It's solved. It was a dev package (knotification) missing. Once more thanks for all!

Report

adwmau

7 months ago

I am getting this error after compiling and installing

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.gmailfeed/contents/ui/main.qml:24:1: module "org.kde.plasma.private.gmailfeed" is not installed

Do you know how to fix this?

Report

ybeltukov

9 months ago

Please find a simple ebiuld to install your nice plasmoid in Gentoo:
https://gist.github.com/ybeltukov/f0633fecda3ddc30e8e2be06904b4ac8

Report

ybeltukov

6 months ago

Now the official ebuild was added as "kde-misc/
gmailfeed".

Report

mixedwrist

1 year ago

Any chance on bringing in multiple accounts check and/or execute custom command instead just opening inbox or the project is dead? (Asking for kaccounts version)

Report

Loacoon

1 year ago

As the title sais, in each update, the applet asks again for my email and password...

Report

Loacoon

1 year ago

Up?

Report

anthon38

1 year ago

You need to have kwalletd5 running

Report

Loacoon

1 year ago

Ok... too bad...

Report

aschkolnik

1 year ago

Hi

When I move my mouse over the Gmail Feed icon, I see the message:
5 unread messages

However, I do not see the subjects.
If I am not mistaken, the subjects are displayed when a new message arrives, but not after.
Is this the intended behavior ?
I would like to see the subjects every time I move the mouse over the icon.
Is there any way to make that happen ?

Report

rosenrot

1 year ago

How to login, if I use the Two-step verification?

Report

terrifyingfungus

1 year ago

You need to click the link bellow and set up an app specific password.
https://security.google.com/settings/security/apppasswords

Report

mathojojo

1 year ago

Installed via ubuntu repositories, but does not show up in the plasmoid list...

strange !

Report

trekjunky

1 year ago

I go to the download widgets and choose Gmail Feed and click Install. It doesn't appear in the list. I reboot and it says it is not installed, so I reinstall it, it asks to overwrite the file, I say yes, and it appears to install, but it doesn't show up in the list. I can't figure this out. Please help.

Report

trekjunky

1 year ago

Also, I have Opensuse Leap 42.1, plasma 5...

Report

naughtypine

1 year ago

Seconded. Also on Leap. I really miss this widget.

Report

anthon38

1 year ago

You can't install it with GetHotNewStuff, because it works only with purely scripted plasmoids. (I know, it's misleading but there is only one category available for Plasma 5 plasmoids)
You have to install it manually. (ie download the source, extract, go in the directory, mkdir build, cd build, cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=lib -DKDE_INSTALL_USE_QT_SYS_PATHS=ON, then make and make install)

Report

trekjunky

1 year ago

It worked. Thanks so much!!!!

Report

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
1.1
updated Mar 23 2015
added Dec 20 2014
downloads today
11
page views today 10