Currency

Plasma 4 Widgets

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
Score 50.0%
Description:

Plasmoid Currency Widget
***********************************************

This KDE4 plasmoid displays exchange rate for cpecicied currencies.
This widget used the FloatRates Feeds API to collect data so credit is
due there.

This Software is published under the terms of the GNU GPL V3 and comes
without any warranty. Feel free to change or distribute this software.

Short installation instruction:
***********************************************
1. From sourcess:
$ tar -xvzf CurrencyPlasmoid_v.0.2_src.tar.gz
$ cd CurrencyPlasmoid
$ mkdir build
$ cd build
$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..
# sudo make install

2. From .deb package:
# sudo dpkg -i CurrencyPlasmoid_0.2_Ubuntu_x64.deb

After instll you need to update plasma, after that you can add widget "currency":
$ kbuildsycoca4
$ kquitapp plasma-desktop
$ plasma-desktop

SUPPORTED CURRENCIES:
***********************************************
Supported currencies listed on the next http://www.floatrates.com/feeds.html.
Currency code specified in parentheses. As example: USD, EUR, RUB....

NOTE: Update exchange rates on the site takes place once a day.For this reason,
there is no need to install frequent updates.

You only need to specify base currency (the currency against which calculates
rates) code into the plasmoid settings and any currency for which you want to
display exchange rate.
In the straight course specified currency codes separated by semicolons that
are calculated to the base currency. Accordingly, in the course of an
inverted calculation is performed with respect to this currency.
For example, the base currency and the USD exchange rate is determined for
the EUR, direct the course will be the USD/EUR, and the inverted
EUR/USD dollar, respectively.

With version 0.2 you can include the option to display percentage changes in
exchange rates in relation to the previous day or the average of the exchange
rates of the week.
The history of rate changes be stored on your computer and increases as update
the working plasmoid (all stored up to 31 entries for all currencies against
the base currency). If one day the plasmoid did not work (the computer was
turned off, and so on) that day is ignored in the calculation of the average
rate for the week. Any changes to the base currency, the data for the previous
saved in history, and when you return it will be restored. The history files
are stored in ~ /.currency/

UNINSTALL v0.1
************************************************
In /build/ directory run:
# sudo make uninstall
Or find and remove next files:
plasma-floatrates-engine.so
plasma_applet_currency.so
plasma-floatrates-engine.desktop
plasma_applet_currency.desktop
~/.floatrates.xml
In Ubuntu .so files placed in dir: /usr/lib/kde4/ and .desktop files placed /usr/share/kde4/services/.
Last changelog:

3 years ago

Changelog
***********************************************

v0.2.2
======
- fixed bug reading date less than 10
- fixed saving of history when you switch the base currency

v0.2
====
- display of percentage changes in exchange rates in relation to the previous day / average rate for the previous week
- font size is changed depending on the size of the window
- fixed view in tray
- a pop-up message with the complete information when you click on the icon in the system tray
- "Update" item in menu

v0.1
====
-Initial Release

CharlesT

3 years ago

I have a screen capture of the results of 0.2.2
Let me know where to send it if you wish to see what I am getting with the current version of CurrencyPlasmoid.

Report

CharlesT

3 years ago

Actually, that was the .deb file. I downloaded the .tar.gz file and compiled and installed from there. That does give me the proper output.
I am using Kubuntu 14.04 LST

Report

zubi

3 years ago

Nice appq but dont work for my
http://wstaw.org/m/2016/03/04/Ex4.png
http://wstaw.org/m/2016/03/04/Ex3.png

Report

C

lexover

3 years ago

Please specify which base currency specified in your plasmoid configuration.

Report

CharlesT

3 years ago

The CMakeLists.txt you mention is below:

# Project Needs a name ofcourse
project(plasma_currency)
set( CMAKE_AUTOMOC ON )
# CMake uses uic in order to generate header files from .ui forms from designer.
set ( CMAKE AUTOUIC ON )
# Auto-generating functions write their headers into the build directory.
# Hence the build directory should be included.
set( CMAKE_INCLUDE_CURRENT_DIR ON )

# Find the required Libaries
find_package(KDE4 REQUIRED)
#find_package(Qt4 COMPONENTS QTCORE QTGUI)
include(KDE4Defaults)

add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
include_directories(
${CMAKE_SOURCE_DIR}
${CMAKE_BINARY_DIR}
${KDE4_INCLUDES}
)

# We add our source code here
set(currency_SRCS plasma-currency.cpp config.cpp)

QT4_WRAP_CPP(qt_H_MOC ui_config.h)
QT4_WRAP_UI(qt_UI_H config.ui)

# Now make sure all files get to the right place

kde4_add_plugin(plasma_applet_currency ${currency_SRCS})
kde4_add_app_icon(currency_SRCS "hi128-apps-currency.png" )
add_library(qt ${qt_UI_H})
target_link_libraries(plasma_applet_currency qt
${KDE4_PLASMA_LIBS} ${KDE4_KDEUI_LIBS})
# Qt4::QtCore Qt4::QtGui)

# install(FILES plasma-applet-currency.desktop
# DESTINATION "~/.kde/share/kde4/services/")

install(TARGETS plasma_applet_currency
DESTINATION ${PLUGIN_INSTALL_DIR})

install(FILES plasma-applet-currency.desktop
DESTINATION ${SERVICES_INSTALL_DIR})
kde4_install_icons( ${ICON_INSTALL_DIR} )

I found no mention of "qt"
Do I need a different CMakeLists.txt?
Thank you!

Report

C

lexover

3 years ago

I fixed the file and upload it again. Download the file again and try to build the application.

Report

CharlesT

3 years ago

The results output on the commandline:

cmake -DCMAKE_INSTALL_PREFIX='kde4-config --prefix' ..
-- The C compiler identification is GNU 4.8.4
-- The CXX compiler identification is GNU 4.8.4
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libXft.so;/usr/lib/x86_64-linux-gnu/libXau.so;/usr/lib/x86_64-linux-gnu/libXdmcp.so;/usr/lib/x86_64-linux-gnu/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libXft.so;/usr/lib/x86_64-linux-gnu/libXau.so;/usr/lib/x86_64-linux-gnu/libXdmcp.so;/usr/lib/x86_64-linux-gnu/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl (found version "5.18.2")
-- Found Phonon: /usr/include (Required is at least version "4.3.80")
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.12 include dir: /usr/include
-- Found KDE 4.12 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found KDE 4.12 include dir: /usr/include
-- Found KDE 4.12 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1472 (add_custom_target):
add_custom_target cannot create target "uninstall" because another target
with the same name already exists. The existing target is a custom target
created in source directory
"/home/tommy/Downloads/CurrencyPlasmoid/CurrencyPlasmoid". See
documentation for policy CMP0002 for more details.
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (find_package)
CurrencyEngine/CMakeLists.txt:7 (find_package)


-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Configuring incomplete, errors occurred!
See also "/home/tommy/Downloads/CurrencyPlasmoid/build/CMakeFiles/CMakeOutput.log".
See also "/home/tommy/Downloads/CurrencyPlasmoid/build/CMakeFiles/CMakeError.log".

/* * * * * * * * * * * * * * * * * * * *
If you want I can send you the error and output logs located in build/CMakeFiles/
*/

Report

CharlesT

3 years ago

-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found KDE 4.12 include dir: /usr/include
-- Found KDE 4.12 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found KDE 4.12 include dir: /usr/include
-- Found KDE 4.12 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1472 (add_custom_target):
add_custom_target cannot create target "uninstall" because another target
with the same name already exists. The existing target is a custom target
created in source directory
"~/Downloads/CurrencyPlasmoid/CurrencyPlasmoid". See
documentation for policy CMP0002 for more details.
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (find_package)
CurrencyEngine/CMakeLists.txt:7 (find_package)


-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Configuring incomplete, errors occurred!
See also "~/Downloads/CurrencyPlasmoid/build/CMakeFiles/CMakeOutput.log".
See also "~/Downloads/CurrencyPlasmoid/build/CMakeFiles/CMakeError.log".

When I entered the line:
cmake -DCMAKE_INSTALL_PREFIX='kde4-config --prefix' ..
I got that message. I can email you the
output and error logs in CMakeFiles if you wish.
Kubuntu 14.04 Trusty, AMD64 8-core, 4GHz. with 512GB SSD

Report

C

lexover

3 years ago

Please try to change CMakeLists.txt in
~/Downloads/CurrencyPlasmoid/CurrencyPlasmoid/
In strings 32, 33 change name "qt" to "qt_currency".
It should look like this:
add_library(qt_currency ${qt_UI_H})
target_link_libraries(plasma_applet_currency qt_currency
Then try again in /buil directrory:
cmake -DCMAKE_INSTALL_PREFIX='kde4-config
--prefix' ..

Report

3 years ago

Changelog
***********************************************

v0.2.2
======
- fixed bug reading date less than 10
- fixed saving of history when you switch the base currency

v0.2
====
- display of percentage changes in exchange rates in relation to the previous day / average rate for the previous week
- font size is changed depending on the size of the window
- fixed view in tray
- a pop-up message with the complete information when you click on the icon in the system tray
- "Update" item in menu

v0.1
====
-Initial Release

12345678910
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.2.1
updated Mar 04 2016
added Jan 30 2016
downloads 24h
0
page views 24h 3