Panel Spacer
KDE Plasma 4 Extensions
Score 86%
Description:

This plasmoid let you put some blank space between the other applets located in a panel. You can set a minimum fixed size and/or allow the spacer
to stretch if there is free space on the right. Optionally, you can display a thin separator line.

This is useful if you want to place a plasmoid on the right in a panel, if you want to do logical groups of icons in your panel, etc.


Some ideas : there should be an easy way to do that in Plasma (maybe something to set the stretch factor or the minimal/maximal size of an applet directly from the panel-settings-toolbar ?). Moreover, maybe the plasma theme specs should be extended to include a SVG for separators.

Comments, patchs, code review (I\'m quite new to this) are welcome :)

---------------------------------
0.1
- Kubuntu Intrepid package (checkinstall)
- Fedora 9 package by Phobeus, thanks ! More info here : http://www.floriansievert.de/linux/repo/english.html
- Kubuntu Hardy package (done with Checkinstall. It install in /usr/lib/kde4).
- Gentoo Ebuild, thanks Devel0per
Last changelog:

8 years ago

-0.2 (source only)
This is the version from Kde SVN playground. Some code cleanup and an improved calculation of the max stretch size (thanks Petri)

- 0.1 first release

itsjustarumour2

5 years ago

Fedora download link appears to be broken, unfortunately.

Report

corwin78

5 years ago

I think that Panel Spacer is not needed anymore, because this functionality is already integrated directly into Panels functionality in new KDE 4.x.x releases.

Report

itsjustarumour2

5 years ago

Ah, so it is, somehow some of my plasmoids had get uninstalled and I missed it. Thanks! :)

Report

jerryru

7 years ago

I'am using kde 4.4.1

I need spacer to center task widget on panel, but when I put spacer(on both sides of task widget) I see "thin vertical lines". What wrong?

Report

ZigmunD

7 years ago

RPM's for openSuSE 11.2:
http://download.opensuse.org/repositories/home:/Zigmund_Freud/openSUSE_11.2/

Report

-luk-

7 years ago

Hi, i've some problems to install it throught the debian package and the source. Panel Space is also for 4.3?

Thanks

Report

C

DanaKil

7 years ago

no idea if it works with 4.3. I will give it a try when I will have some free time

Report

mkyral

7 years ago

In Kde 4.3 is spacer included.

Report

-luk-

7 years ago

Oh thanks, it works :)

Report

Gen2ly

8 years ago

I'f I set the size to below default value the spacer(s) will change place when I log in again. Tried with new plasma configs and problem persists.

Report

C

DanaKil

8 years ago

Hi,
I don't think this is directly related to Panel spacer because it don't manage its own positioning... so it's likely a plasma bug. Please report it if you can, thanks :)

Report

TheAbu

8 years ago

Very useful, thanks a lot :)

Report

rgheck

8 years ago

After a fair bit of work, I was able to compile the 0.2 sources on F11. Here's what I had to do.

First, remove the line:

find_package(Plasma REQUIRED)

On line 19, change

PLASMA_LIBS

to

KDE4_PLASMA_LIBS

And then, most importantly, edit the file /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake and comment out the line producing the line reading:

message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")

This should probably get changed back...

Report

Grindcore

7 years ago

I always had this error, when trying to compile the source here under Kubuntu 9.10.

Now finally with your instructions it worked for me.

Thank you =)!

Report

Grindcore

8 years ago

I have a quite stupid problem: The build/install process was succesful and I can open the plasmoid the usual way through the "add plasmoid"-menu.

It adds a thin vertical line to my panel (that's good) but it's so small, that I just don't manage to open the preferences when clicking right and trying to hit it probably (that's bad ^^).

Any ideas :S?

Thanks

Report

Grindcore

8 years ago

Me failed hard... Just ignore my post.

Sorry ^^

Report

hurricanek

8 years ago

kde 4.3beta seems can not have correct alignment, this with stasks will make sense!

Report

marcosgildavid

8 years ago

Hello
Can you please help me?
I'm having some trouble compiling this app:
$make
Generating panelspacer.moc
[ 0%] Built target plasma_applet_panelspacer_automoc
[ 33%] Generating ui_panelspacerConfig.h
[ 66%] Building CXX object CMakeFiles/plasma_applet_panelspacer.dir/plasma_applet_panelspacer_automoc.o
[100%] Building CXX object CMakeFiles/plasma_applet_panelspacer.dir/panelspacer.o
Linking CXX shared module lib/plasma_applet_panelspacer.so
CMakeFiles/plasma_applet_panelspacer.dir/panelspacer.o: In function `PanelSpacer::qt_metacast(char const*)':
/home/mdavid/downloads/lookandfeel/plasma/Panelspacer_from_svn_pour_kdelook-tmp/build/panelspacer.moc:71: undefined reference to `Plasma::Applet::qt_metacast(char const*)'
CMakeFiles/plasma_applet_panelspacer.dir/panelspacer.o: In function `PanelSpacer::slotSpacerSizeChanged(int)':
/home/mdavid/downloads/lookandfeel/plasma/Panelspacer_from_svn_pour_kdelook-tmp/panelspacer.cpp:260: undefined reference to `Plasma::Applet::updateConstraints(QFlags<Plasma::Constraint>)'
CMakeFiles/plasma_applet_panelspacer.dir/panelspacer.o: In function `PanelSpacer::slotSeparatorPositionChanged(int)':
/home/mdavid/downloads/lookandfeel/plasma/Panelspacer_from_svn_pour_kdelook-tmp/panelspacer.cpp:242: undefined reference to `Plasma::Applet::updateConstraints(QFlags<Plasma::Constraint>)'
CMakeFiles/plasma_applet_panelspacer.dir/panelspacer.o: In function `PanelSpacer::slotSpacerStretchChanged(bool)':
/home/mdavid/downloads/lookandfeel/plasma/Panelspacer_from_svn_pour_kdelook-tmp/panelspacer.cpp:236: undefined reference to `Plasma::Applet::updateConstraints(QFlags<Plasma::Constraint>)'
CMakeFiles/plasma_applet_panelspacer.dir/panelspacer.o: In function `PanelSpacer::slotSeparatorStyleChanged(int)':
/home/mdavid/downloads/lookandfeel/plasma/Panelspacer_from_svn_pour_kdelook-tmp/panelspacer.cpp:254: undefined reference to `Plasma::Applet::updateConstraints(QFlags<Plasma::Constraint>)'
CMakeFiles/plasma_applet_panelspacer.dir/panelspacer.o: In function `PanelSpacer':
/home/mdavid/downloads/lookandfeel/plasma/Panelspacer_from_svn_pour_kdelook-tmp/panelspacer.cpp:35: undefined reference to `Plasma::Applet::Applet(QObject*, QList<QVariant> const&)'
/home/mdavid/downloads/lookandfeel/plasma/Panelspacer_from_svn_pour_kdelook-tmp/panelspacer.cpp:35: undefined reference to `Plasma::Applet::Applet(QObject*, QList<QVariant> const&)'

I'm using latest KDE (kdebase4-4.2.68.svn945504-1.2)

Thanks in advance.

Report

rizwanrafique

8 years ago

Here is how to compile it on Kubuntu with KDE 4.2. I couldn't compile the source downloaded from here. The one from KDE trunk/playground should work fine.

Quote:
mkdir ~/tmp

cd ~/tmp

sudo apt-get install libkonq5-dev libkonq5 cmake libplasma-dev kdelibs5-dev g++ kdebase-dev subversion

svn co svn://anonsvn.kde.org/home/kde/trunk/playground/base/plasma/applets/panelspacer

cd panelspacer

mkdir build

cd build

cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..

make

sudo make install


Then add it usually from Panel Settings -> Add Widgets

Report

corwin78

8 years ago

Thank you very much, it is working perfectly.

Report

pavel23

8 years ago

Alas, no go. The build/install worked smoothly, but the applet is nowhere to be found in the applet-installer.

Any thougths on how to get it working?

(Kubuntu 9.04 with KDE 4.2.3)

regards,
Paul

Report

Grindcore

8 years ago

Have you already tried to restart Plasma?

Quote:kquitapp plasma
plasma

Report

rizwanrafique

8 years ago

Here is how to compile it on Kubuntu with KDE 4.2. I couldn't compile the source downloaded from here. The one from KDE trunk/playground should work fine.

Quote:
mkdir ~/tmp

cd ~/tmp

sudo apt-get install libkonq5-dev libkonq5 cmake libplasma-dev kdelibs5-dev g++ kdebase-dev subversion

svn co svn://anonsvn.kde.org/home/kde/trunk/playground/base/plasma/applets/panelspacer

cd panelspacer

mkdir build

cd build

cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..

make

sudo make install


Then add it usually from Panel Settings -> Add Widgets

Report

corwin78

8 years ago

Hello, I trying compile it under Kubuntu 8.10 64bit and KDE 4.2.1, but I got following message:

Make Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:84 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/breskmic/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:5 (find_package)

-- Configuring incomplete, errors occurred!

I think that maybe some DEV package is missing. Can you give me some advice which can be it? Thanks.

Report

devel0per

8 years ago

Ebuild with kde-4.2 build patch is pushed into gentoo overlay - kde-testing.

http://git.overlays.gentoo.org/gitweb/?p=proj/kde.git;a=commitdiff;h=443a9e8a4ac9e6b917b6799840699da131abe711

Report

8 years ago

-0.2 (source only)
This is the version from Kde SVN playground. Some code cleanup and an improved calculation of the max stretch size (thanks Petri)

- 0.1 first release

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.2
updated Dec 14 2008
added Sep 14 2008
downloads today
0
page views today 5