Plasma 5 Monitoring

Source (link to git-repo or to original if based on someone elses unmodified work): https://github.com/dwardor/plasma-applet-fanspeed-monitor

0
Score 46.0%
Description:

Plasma 5 applet for monitoring Fan Speed sensors (lmsensors and nvidia-smi if applicable).

Coding very largely based off of Kotelnik's thermal Monitor https://github.com/kotelnik/plasma-applet-thermal-monitor.

Original Icon is Fan Icon made by Freepik from www.flaticon.com (https://www.flaticon.com/free-icon/fan_22846) before changing the colors.


REQUIRED DEPENDENCIES
- qt5-graphicaleffects
- e.g. package for kubuntu users: libqt5qml-graphicaleffects

HOW TO INSTALL
- Add Widgets... -> Get new widgets -> Download new plasma widgets
- find this applet and install through the first item with .plasmoid extension
Last changelog:

v1.1.1 1 month ago

Fix Width to Height ratio to 1 decimal

baltolkien

10 days ago

I like this widget but I can't add Source to Fan Speed Monitor.
I have lm-sensors and use Plasma 5.18.
Any suggestion?
Thanks in advanced

Report

3

parecs

22 days ago

3 Monitor always says just "OFF" for me.

Tried using it with GPU fan speed (which is what I care about) and it only says "OFF". Have an Nvidia card and nvidia-smi command DOES show fan speed correctly.

Also tried using it for cpu/mobo fan speeds just to see if it would report 0 (since lm_sensor doesn't support my mobo) but that also just said "OFF".

Report

C

dwardor

22 days ago

OFF is normal behavior if speed is 0 (which happens if returned as 0 or undefined).
Thermal monitor does the same thing if Temp is 0
ui/TemperatureItem.qml: property bool isOff: temperature === 0
ui/TemperatureItem.qml: text: isOff ? i18n('OFF') : TemperatureUtils.getTemperatureStr(temperature, temperatureUnit)

Report

3

parecs

18 days ago

Ah, thanks for that. That would explain the CPU fan being reported as off since I know my mobo has problems with lm_sensor but still doesn't explain why I can't see GPU fan.

Report

3

parecs

22 days ago

Doesn't work for me. Indicator just says "OFF" for eternity. Thermal Monitor applet works perfectly though.

Report

C

dwardor

22 days ago

What version of plasma are you using ? I have the exact opposite behavior... Official Thermal monitor showing OFF for CPU Temps for eternity.
Must admit I have not tested GPU fan speed as I don't have one... Just coded it as I expect it to work based on what thermal monitor did...
What does "nvidia-smi --query-gpu=fan.speed --format=csv,noheader" return ?

Report

3

parecs

18 days ago

It returns whats expected (same fan speed as reported by nvidia-settings gui as well as just nvidia-smi with no parameters) (I'll also note it is above 0 at all times so Fan Speed Monitor shouldn't be saying off)

The plasma version i'm using is 5.17.5.

Thermal Monitor reports both CPU and GPU temps correctly while Fan Speed Monitor says "OFF" no matter what settings it has.

Report

C

dwardor

22 days ago

Out of curiosity what version of plasma are you using ?
I ask as Official Thermal Monitor stopped working for me at some point and so I had to patch it (see https://github.com/kotelnik/plasma-applet-thermal-monitor/pull/62) to get it to work in plasma >=5.17.4
I reused the same patches for Fanspeed-monitor.

Report

v1.1.1 1 month ago

Fix Width to Height ratio to 1 decimal

1st release 1 month ago

1st release

12345678910
1
product-maker parecs Feb 02 2020 3 bad
Monitor always says just "OFF" for me. Tried using it with GPU fan speed (which is what I care about) and it only says "OFF". Have an Nvidia card and nvidia-smi command DOES show fan speed correctly. Also tried using it for cpu/mobo fan speeds just to see if it would report 0 (since lm_sensor doesn't support my mobo) but that also just said "OFF".
product-maker Base: 4 x 5.0 Ratings
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
GPLv2 only
version
1.1.1
updated Jan 01 2020
added Dec 28 2019
downloads 24h
29
mediaviews 24h 0
pageviews 24h 17